3. Take input from a file (Input-Assignment1-Problem-1.txt), which will first have the number of test cases (T), then a series of "T" numbers, separated by spaces. For each input number in the series of "T" numbers, call getRandomArray(size) to get a randomly generated array of size equal to that number, run selection sort, merge sort and insertion sort on the randomly generated array. For each sorting algorithm, and each randomly generated array from input sizes in the file, print the size & time elapsed to an output file named -Output-Assignment-1-Problem-1.txt

Database System Concepts
7th Edition
ISBN:9780078022159
Author:Abraham Silberschatz Professor, Henry F. Korth, S. Sudarshan
Publisher:Abraham Silberschatz Professor, Henry F. Korth, S. Sudarshan
Chapter1: Introduction
Section: Chapter Questions
Problem 1PE
icon
Related questions
Question

Do not copy. I need the code in c++ format.

3. Take input from a file (Input-Assignment1-Problem-1.txt), which will first have
the number of test cases (T), then a series of "T" numbers, separated by spaces.
For each input number in the series of "T" numbers, call getRandomArray(size)
to get a randomly generated array of size equal to that number, run selection
sort, merge sort and insertion sort on the randomly generated array.
For each sorting algorithm, and each randomly generated array from input
sizes in the file, print the size & time elapsed to an output file named
<ROLL>-Output-Assignment-1-Problem-1.txt
Input file format:
T (number of test cases)
X1 X2 X3 Xạ X6 .... Xr (A series of "T" numbers, separated by a space)
Sample Input (Input-Assignment1-Problem-1.txt):
13
15 20 25 30 50 100 150 200 250 500 1000 2000 10000
Sample Output (eg. 1505022-Output-Assignment1-Problem1.txt)
Test Case #1
Size: 15
Technique: Selection, Time: 150ms
Technique: Insertion, Time: 200ms
Technique: Merge, Time: 30ms
Test Case #2
Sample Time Code:
# include <ctime>
# include <iostream>
using namespace std;
int main(){
long t1 = clock();
II Required task to be timed here.
int "arr = getRandomArray(size)
selection_sort(arr, size)
long t2 = clock();
long t_elapsed = t2 - t1;
cout << "Time Elapsed: " <<t_elapsed << " s" < endl;
long t1 = clock();
II Required task to be timed here.
int "arr = getRandomArray(size)
insertion_sort(arr, size)
long t2 = clock();
long t_elapsed = t2 - t1;
cout << "Time Elapsed: " <t_elapsed << “s" << endl;
Transcribed Image Text:3. Take input from a file (Input-Assignment1-Problem-1.txt), which will first have the number of test cases (T), then a series of "T" numbers, separated by spaces. For each input number in the series of "T" numbers, call getRandomArray(size) to get a randomly generated array of size equal to that number, run selection sort, merge sort and insertion sort on the randomly generated array. For each sorting algorithm, and each randomly generated array from input sizes in the file, print the size & time elapsed to an output file named <ROLL>-Output-Assignment-1-Problem-1.txt Input file format: T (number of test cases) X1 X2 X3 Xạ X6 .... Xr (A series of "T" numbers, separated by a space) Sample Input (Input-Assignment1-Problem-1.txt): 13 15 20 25 30 50 100 150 200 250 500 1000 2000 10000 Sample Output (eg. 1505022-Output-Assignment1-Problem1.txt) Test Case #1 Size: 15 Technique: Selection, Time: 150ms Technique: Insertion, Time: 200ms Technique: Merge, Time: 30ms Test Case #2 Sample Time Code: # include <ctime> # include <iostream> using namespace std; int main(){ long t1 = clock(); II Required task to be timed here. int "arr = getRandomArray(size) selection_sort(arr, size) long t2 = clock(); long t_elapsed = t2 - t1; cout << "Time Elapsed: " <<t_elapsed << " s" < endl; long t1 = clock(); II Required task to be timed here. int "arr = getRandomArray(size) insertion_sort(arr, size) long t2 = clock(); long t_elapsed = t2 - t1; cout << "Time Elapsed: " <t_elapsed << “s" << endl;
Expert Solution
steps

Step by step

Solved in 2 steps

Blurred answer
Knowledge Booster
Constants and Variables
Learn more about
Need a deep-dive on the concept behind this application? Look no further. Learn more about this topic, computer-science and related others by exploring similar questions and additional content below.
Similar questions
  • SEE MORE QUESTIONS
Recommended textbooks for you
Database System Concepts
Database System Concepts
Computer Science
ISBN:
9780078022159
Author:
Abraham Silberschatz Professor, Henry F. Korth, S. Sudarshan
Publisher:
McGraw-Hill Education
Starting Out with Python (4th Edition)
Starting Out with Python (4th Edition)
Computer Science
ISBN:
9780134444321
Author:
Tony Gaddis
Publisher:
PEARSON
Digital Fundamentals (11th Edition)
Digital Fundamentals (11th Edition)
Computer Science
ISBN:
9780132737968
Author:
Thomas L. Floyd
Publisher:
PEARSON
C How to Program (8th Edition)
C How to Program (8th Edition)
Computer Science
ISBN:
9780133976892
Author:
Paul J. Deitel, Harvey Deitel
Publisher:
PEARSON
Database Systems: Design, Implementation, & Manag…
Database Systems: Design, Implementation, & Manag…
Computer Science
ISBN:
9781337627900
Author:
Carlos Coronel, Steven Morris
Publisher:
Cengage Learning
Programmable Logic Controllers
Programmable Logic Controllers
Computer Science
ISBN:
9780073373843
Author:
Frank D. Petruzella
Publisher:
McGraw-Hill Education