Question: 1 A perfect number is an integer that is the sum of its positive proper  divisors (all divisors except itself). For example, 6 is a perfect number.  The divisors of 6 except itself are 1,2 and 3. The sum of the proper  divisors of 6 is 6. Thus 6 is a perfect number. You have to take integers  as input and continue taking input until the word “STOP” is given as input.  After taking the inputs you have to classify the integers as Perfect and  Imperfect and store it in a dictionary(Please see the output for better  understanding). [Note: You CANNOT use any built in functions EXCEPT input(),range(),print()] Sample Input : 6 10 8 25 28 100 496 530 STOP Sample Output:(No need to follow the output format. Just print the  resultant dictionary.) { Perfect: [6,28,496], Imperfect: [10,8,25,100,530] }

Database System Concepts
7th Edition
ISBN:9780078022159
Author:Abraham Silberschatz Professor, Henry F. Korth, S. Sudarshan
Publisher:Abraham Silberschatz Professor, Henry F. Korth, S. Sudarshan
Chapter1: Introduction
Section: Chapter Questions
Problem 1PE
icon
Related questions
Question

WRITE A PYTHON PROGRAM

 

Question: 1
A perfect number is an integer that is the sum of its positive proper 
divisors (all divisors except itself). For example, 6 is a perfect number. 
The divisors of 6 except itself are 1,2 and 3. The sum of the proper 
divisors of 6 is 6. Thus 6 is a perfect number. You have to take integers 
as input and continue taking input until the word “STOP” is given as input. 
After taking the inputs you have to classify the integers as Perfect and 
Imperfect and store it in a dictionary(Please see the output for better 
understanding).
[Note: You CANNOT use any built in functions EXCEPT input(),range(),print()]

Sample Input :
6
10
8
25
28
100
496
530
STOP

Sample Output:(No need to follow the output format. Just print the 
resultant dictionary.)
{
Perfect: [6,28,496],
Imperfect: [10,8,25,100,530]
}

Question: 2
Implement the design of the Groceries and Buyer classes so that the 
following code generates the output below:

#Write your code here
buyer1 = Buyer('Ross', 'CL23')
print('1.===============================')
print(buyer1)
item1 = Groceries('Mango', 'Fruits')
print('2.===============================')
print(item1)
print('3.===============================')
print(Groceries.items)
print('4.===============================')
Groceries.add_items('Packaged',['Flour 90', 'Noodles 30', 'Soybean-Oil 
150'])
print(f'Updated Item List:\n{Groceries.items}')
print('5.===============================')
item2 = Groceries('Flour', 'Packaged', 3)
print(item2)
print('6.===============================')
buyer1.create_bill(item1, item2)
print('7.===============================')
item3 = Groceries('Orange', 'Fruits', 3)
print(item3)
print('8.===============================')
item4 = Groceries('Rice', 'Packaged', 2)
print(item4)
print('9.===============================')
buyer2 = Buyer('Chandler')
print(buyer2)
print('10.==============================')
buyer2.create_bill(item1, item3, item4)

Expert Solution
trending now

Trending now

This is a popular solution!

steps

Step by step

Solved in 3 steps with 1 images

Blurred answer
Knowledge Booster
Mathematical functions
Learn more about
Need a deep-dive on the concept behind this application? Look no further. Learn more about this topic, computer-science and related others by exploring similar questions and additional content below.
Similar questions
  • SEE MORE QUESTIONS
Recommended textbooks for you
Database System Concepts
Database System Concepts
Computer Science
ISBN:
9780078022159
Author:
Abraham Silberschatz Professor, Henry F. Korth, S. Sudarshan
Publisher:
McGraw-Hill Education
Starting Out with Python (4th Edition)
Starting Out with Python (4th Edition)
Computer Science
ISBN:
9780134444321
Author:
Tony Gaddis
Publisher:
PEARSON
Digital Fundamentals (11th Edition)
Digital Fundamentals (11th Edition)
Computer Science
ISBN:
9780132737968
Author:
Thomas L. Floyd
Publisher:
PEARSON
C How to Program (8th Edition)
C How to Program (8th Edition)
Computer Science
ISBN:
9780133976892
Author:
Paul J. Deitel, Harvey Deitel
Publisher:
PEARSON
Database Systems: Design, Implementation, & Manag…
Database Systems: Design, Implementation, & Manag…
Computer Science
ISBN:
9781337627900
Author:
Carlos Coronel, Steven Morris
Publisher:
Cengage Learning
Programmable Logic Controllers
Programmable Logic Controllers
Computer Science
ISBN:
9780073373843
Author:
Frank D. Petruzella
Publisher:
McGraw-Hill Education