Can you explain this code step by step in a detail way?

Database System Concepts
7th Edition
ISBN:9780078022159
Author:Abraham Silberschatz Professor, Henry F. Korth, S. Sudarshan
Publisher:Abraham Silberschatz Professor, Henry F. Korth, S. Sudarshan
Chapter1: Introduction
Section: Chapter Questions
Problem 1PE
icon
Related questions
Question

Night Sir. Can you explain this code step by step in a detail way? Thx.

Duplicate Friends
Jojo is trying to make a mini friend list app for his practicum project. His prototype app can store N number of names in the storage. To make it unique, he built a mass-insertion system for the names and made sure that no duplicate names may exist in the storage. If a duplicate name exists, the app will output the number of duplicate names on the screen.


Format Input
The application will ask for N as the number of names to be stored, followed by N consecutive names S1, S2, ..., SN as strings.


Format Output
The number of name duplicates.


Constraints
1 ≤ ? ≤ 1000
1 ≤ |??| ≤ 100

Sample Input 
8
Tuna
Hanoi
Hanoi
Natnat
Natnat
Ceye
Diong
Tuna

Sample Output
You have 3 duplicate name(s).

Explanation:
If a single name is inserted more than two times, it is still considered as a single duplicate.
Note:
The output is in a single line.
Don't forget to add the newline character after printing the output.

 

#include <stdio.h>
#include <string.h>
struct names
{
char s[150];
};
int main(void)
{
int N,k,l,count = 0;
scanf("%d",&N);
int freq[N];
struct names arr[N];
for(k = 0; k < N; k++)
scanf("%s",&arr[k].s);

for(k = 0; k < N; k++)
{
count = 0;
for(l = 0; l < N;l++)
{
if(strcmp(arr[k].s,arr[l].s) == 0)
{
count++;
freq[l] = count;
}
}
}
count = 0;
for(k = 0 ;k < N;k++)
{
if(freq[k] == 2)
count++;
}

printf("You have %d duplicate name(s).\n",count);
return 0;
}

Expert Solution
trending now

Trending now

This is a popular solution!

steps

Step by step

Solved in 2 steps

Blurred answer
Knowledge Booster
Graphical User Interface
Learn more about
Need a deep-dive on the concept behind this application? Look no further. Learn more about this topic, computer-science and related others by exploring similar questions and additional content below.
Similar questions
  • SEE MORE QUESTIONS
Recommended textbooks for you
Database System Concepts
Database System Concepts
Computer Science
ISBN:
9780078022159
Author:
Abraham Silberschatz Professor, Henry F. Korth, S. Sudarshan
Publisher:
McGraw-Hill Education
Starting Out with Python (4th Edition)
Starting Out with Python (4th Edition)
Computer Science
ISBN:
9780134444321
Author:
Tony Gaddis
Publisher:
PEARSON
Digital Fundamentals (11th Edition)
Digital Fundamentals (11th Edition)
Computer Science
ISBN:
9780132737968
Author:
Thomas L. Floyd
Publisher:
PEARSON
C How to Program (8th Edition)
C How to Program (8th Edition)
Computer Science
ISBN:
9780133976892
Author:
Paul J. Deitel, Harvey Deitel
Publisher:
PEARSON
Database Systems: Design, Implementation, & Manag…
Database Systems: Design, Implementation, & Manag…
Computer Science
ISBN:
9781337627900
Author:
Carlos Coronel, Steven Morris
Publisher:
Cengage Learning
Programmable Logic Controllers
Programmable Logic Controllers
Computer Science
ISBN:
9780073373843
Author:
Frank D. Petruzella
Publisher:
McGraw-Hill Education